Knowledge Base/League of Legends Player Support/Technical Support

League of Legends Mac Client Minimum System Requirements

choochoo
posted this on March 01, 2013 14:26

Mac_MinimumRequirements.png

The following are the minimum and recommended system requirements for running the beta League of Legends client on a Mac. 

Note: At this time, the Intel GMA Series of graphics processors are not supported. We apologize for any inconvenience caused. 

Minimum System Requirements

  • Mac OS X 10.6.8 or higher
  • 2 GB RAM (4 GB is strongly recommended)
  • 5 GB available hard disk space
  • NVIDIA GeForce 8600M GT or ATI Radeon HD 2600 or better

Recommended System Requirements

  • Mac OS X 10.7.x or higher
  • 4 GB of RAM or higher 
  • 10 GB available hard disk space
  • NVIDIA GeForce GT 330M or ATI Radeon HD 4670 or better
 
Topic is closed for comments